Tegnap este tapasztaltam, hogy a WordPress oldalam URL-je nem az általam beállított módon jelenik meg, mert a végéhez egy változót mindig hozzácsapott (http://www.purpleonlinemedia.hu/?v=35b5282113b8) .

El sem tudtam képzelni, hogy ez miért volt. Gondoltam a szokásos Google keresést megcsinálom és hátha segítséget kapok. Tehát beírtam a következő kifejezéseket: WordPress URL problem v=35b5282113b8, WordPress v=35b5282113b8, v=35b5282113b8. Az eredmény sokkolt, mert csak 3 pontos egyezést találtam, ezt láthatjátok a csatolt képen is.

wordpress-weboldal-woocommerce-hiba-keresesi-eredmeny

WordPress URL hiba találatok – 3db

Ezek nem sokat segítettek, így tovább keresgéltem. Sajnos sikertelenül. Fáradt és motiválatlan is voltam, így elkövettem egy hibát is, így kitiltottam magam az admin felületről, de ez egy másik sztori. Tehát a hiba fenn állt, de az oldal elérhető volt, így nyugodt szívvel feküdhettem le.

Másnap reggel nem hagyott nyugodni a probléma, ezért gondolkoztam tovább:

  • Milyen új plugint telepítettem?
  • Milyen plugin frissült?
  • Frissült-e a téma?
  • Kellett-e bármit átállítanom?

A kérdések többségégre igen volt a válasz:

  • Telepítettem új plugint, de nem tűnt fel a változás.
  • Frissítettem is, de nem láttam semmi változást.
  • A témát a napokban frissítettem, sajnos a CSS rovására.
  • Ezek következtében és hogy be akarom indítani a WordPress weboldalak futószalagos gyártását, így bele-bele kell nyúlni a beállításokba

A konklúzió a következő volt:

  • az új pluginek nem voltak fontosak, így kikapcsoltam őket
  • a téma frissítése csak a megjelenésben jelentkezett problémaként
  • a kisebb beállítások nem sok vizet zavartak
  • VISZONT a pluginek frissítése során egy működése nem volt kielégítő

Ez a WooCommerce volt. Az első jele az volt, amikor terméket akartam vásárolni, akkor sajnos a felület szétcsúszott és nem üzemelt optimálisan. A keresgélés során az is feltűnt, hogy au URL kapott egy plusz változót. Semmilyen beállítással nem tudtam kikapcsolni, így elkezdtem az új és a frissült (valamint a nem használt) plugineket ki kapcsolni és néztem, hogy van-e változás.

wordpress-weboldal-woocommerce-hiba-URL

Nem néz ki a hiba valami szépen :(

A hiba végül nem hiba volt, csak a Woocomerce Alapértelmezett vásárló telephely beállítás egyik mellékterméke. 

  • Ha nincs beállítva semmi akkor nem jelenik meg az URL végén a ?v= változó és értéke
  • Ha Földrajzi helymeghatározás van bekapcsolva, akkor szintén nem jelenik meg 
  • Ha Földrajzi helymeghatározás (oldal gyorsírótárazási támogatással), akkor megjelenik  az URL végén a ?v= változó és értéke

Tehát fény derült a problémára, ami valójában nem is volt az,